Phong Breaks in Cinema 4D: Is there a workaround?

As has been noted in previous posts, the phong settings in a Cinema 4D are not imported correctly in to Unity, specifically the phong breaks. Until Maxon provide a fix, has anyone found a workflow for getting around this?

For instance is there any intermediate app (Maya/Max/Blender etc.) That could import the C4D file, re-export it as fbx with the correct phong settings?

I’m dead in the water with one particular model that has a combination of curves and geometric figures; polygons at similar angles need to be smoothed in some cases but not others. Other than re-saving the model as a dozen different models, I’m a bit stuck :slight_smile:

Thanks for any ideas.



Edit:

Rejoice! :slight_smile:

As of Unity 3.5 Beta in combination with C4D R13, this is now fixed

Steve

I’d love to find a definitve solution to this, but for now I use this workaround that seems to work well enough in Unity. Here’s an handy 'n easy tutorial.

Let’s say you have this:
alt text

…and want to do this:
alt text

These are the edges that make the break. But instead of selecting them…
alt text

…select all the adjacent polygons. Just select the ones on one side of the break.
alt text

Now right click, and select Disconnect. This dialog will appear. Leave the box ticked, then click Ok…
alt text

…and you will get this.
alt text

Now, see these vertices? They are all doubled up and must be welded again. Select Live Selection tool, uncheck Only Select Visible Elements, select them one by one and run the Weld command on them one by one. After you are done, unselect all, and you will have…
alt text

…this. Hey, looks legit.
alt text

This mesh looks exactly as it would do with edge breaks, but without using edge breaks, so it will be fully readable in Unity. Just remember to set Normals to Calculate and Smoothing Angle to 180° in the Unity FBXImporter panel.

If this won’t work either, try to do one last simple thing: in C4D, after you have welded back the vertices, select again the same polygons you selected before, and move them just a bit so nobody wil notice (like 0.01, or 0.0000001), any direction will do. Import them back in Unity, and this should fix everything once for all.

Hope it helps, let me know!