Pivot Point Change Doesn't Apply

Just what the title says. I use the sprite editor to change the position of the pivot point and hit apply when I have it where I want it, but when I drag the sprite into the editor, the pivot point is still in the center. I watched videos, tried many times, but nothing works. I follow every step throughly, but it just doesn’t change anything.

Please help, I’m gonna cry.

I don’t know if you already got it figured out, but here’s a solution if not:
If your saying that the pivot point is in the center on the Scene view, right above the standard place where the tabs for Scene and Game is, there should be a button that says “Center”. Change this to “Pivot” by clicking on it. This should set the pivot point to where you placed it in the Sprite Editor.

I hope it helped!

You have to select this option “pivot”


You have to select this option,You have to select this option,hello my friend
You have to leave this option pivot

This may help you .Try to change you pictures file into many types such as png. or jpeg .Because the problem may cause from the pictures file.