Plastic SCM problem

I was using unity on my last pc. Now i am on a new pc and i install unity this one. Buy when i created a project it says :

“NullReferenceException: Object reference not set to an instance of an object
Unity.PlasticSCM.Editor.ProjectDownloader.ParseArguments.GetOrganizationNameFromData (System.String data) (at Library/PackageCache/com.unity.collab-proxy@2.0.3/Editor/PlasticSCM/CloudProjectDownloader/ParseArguments.cs:42)
Unity.PlasticSCM.Editor.ProjectDownloader.ParseArguments.CloudOrganization (System.Collections.Generic.Dictionary`2[TKey,TValue] args) (at Library/PackageCache/com.unity.collab-proxy@2.0.3/Editor/PlasticSCM/CloudProjectDownloader/ParseArguments.cs:24)
Unity.PlasticSCM.Editor.ProjectDownloader.CloudProjectDownloader.DownloadRepository (System.String unityAccessToken, System.String commandLineArgs) (at Library/PackageCache/com.unity.collab-proxy@2.0.3/Editor/PlasticSCM/CloudProjectDownloader/CloudProjectDownloader.cs:63)
Unity.PlasticSCM.Editor.ProjectDownloader.CloudProjectDownloader.DownloadRepository (System.String unityAccessToken) (at Library/PackageCache/com.unity.collab-proxy@2.0.3/Editor/PlasticSCM/CloudProjectDownloader/CloudProjectDownloader.cs:51)
Unity.PlasticSCM.Editor.ProjectDownloader.CloudProjectDownloader.Execute (System.String unityAccessToken) (at Library/PackageCache/com.unity.collab-proxy@2.0.3/Editor/PlasticSCM/CloudProjectDownloader/CloudProjectDownloader.cs:43)
Unity.PlasticSCM.Editor.ProjectDownloader.CloudProjectDownloader.RunOnceWhenAccessTokenIsInitialized () (at Library/PackageCache/com.unity.collab-proxy@2.0.3/Editor/PlasticSCM/CloudProjectDownloader/CloudProjectDownloader.cs:32)
UnityEditor.EditorApplication.Internal_CallUpdateFunctions () (at <9959c9185b684a4d9d56448296fb9048>:0)”

I searched on google but i couldn fix the problem pls help me.

Simply updating the Version Control Package through the package manager fixed the issue (to 2.0.4)

It seems there is something wrong with plastic, did you somehow also copy the plastic version over to the new PC? and it losts a reference? Try this:

Update Unity and Plastic SCM:
Make sure you’re using the latest version of Unity and the Plastic SCM package. Update Unity to the latest version through the Unity Hub, and update the Plastic SCM package via the Package Manager (Window > Package Manager).

Check Unity account and organization:
Ensure that you’re logged into the correct Unity account and that your organization is properly configured. To check this, go to Edit > Preferences > Unity Services in the Unity editor.

Re-import the Plastic SCM package:
You can try re-importing the Plastic SCM package by removing and then re-adding it via the Package Manager (Window > Package Manager). This can help fix any issues related to corrupted or missing files.

Reset Plastic SCM settings:
Resetting Plastic SCM settings may help resolve the issue. To do this, navigate to Edit > Preferences > Plastic SCM in the Unity editor and click on the “Reset” button to reset the settings.

Create a new project:
If the issue persists, you can try creating a new Unity project and check if the problem still occurs. If it doesn’t, you can manually copy your assets and settings from the old project to the new one.

Reinstall Unity:
As a last resort, you can try uninstalling and reinstalling Unity to fix any corrupted files or configurations that might be causing the issue.

Remember to always back up your project before trying any of these solutions to ensure you don’t lose any work.

Same here. The option Edit > Preferences > Plastic SCM does not exist in the project. Likewise, there is no Plastic SCM package; I’m using the free version of Unity and I don’t even know what that is. Is that the Unity source control system? I’m not using that. Just a simple test project in the free version of Unity. There appears to be a production bug in the latest LTS that needs a hotfix. Seems like licensing is maybe getting confused?

I noticed this error happening with new projects, closing Unity and opening the new project resolved the issue for me (it only happens when you “create a new project”, but not if you load this new project).

I am new to Unity. So i made a new project today and it showed me this error. I got scared what i have touched but after 5 minutes i restarted the program and it just worked with no errors. My program was 2D empty. I dont know if i am lucky or not but unfortunately I cant help you…,So i restarted the project and it work. I do not know if i am lucky or not but it just worked. My project was 2D empty. I had the same problem as you. I got scared because it is my first time working with this but i do not know how it fixed itself.

Unity latest 2021.3.23f LTS version giving this error

I had the same issue on the very first time I created a project and opened it. For me just restarting Unity also seemed to fix it.

Removing the Version Control Package from the project resolves the error.

If somebody knows why removing this package is bad, I’d be interested in hearing about it as I have 0 experience with this package.

Addition: if you add Version Control back in, then it is working.

updating the version control system from the package manager fixed my issue for unity2021.3.24f.