Player data archive not found at /var/containers

Hi guys. I have the following issue when trying to build the game on the device. I searched for a few days already for something to help me out but the only things I found were Linux related. I tried a few things but as I’m not using Linux, nothing helped me out. If you can help me or guide me in the right direction, I would very much appreciate it. Thank you in advance
(Currently I’m using Unity 2017.1.3 and xCode 9.3)
Here is the full error:
2018-08-05 17:37:55.173329+0300 juicecats[1257:413421] [DYMTLInitPlatform] platform initialization successful

2018-08-05 17:37:55.205572+0300 juicecats[1257:413123] → registered mono modules 0x105ed5620
→ applicationDidFinishLaunching()
Player data archive not found at /var/containers/Bundle/Application/752BB5D0-3915-4D0C-BB0E-722F46788C09/juicecats.app/Data/data.unity3d, using local filesystem
2018-08-05 17:37:55.474652+0300 juicecats[1257:413123] Metal GPU Frame Capture Enabled
2018-08-05 17:37:55.475372+0300 juicecats[1257:413123] Metal API Validation Disabled
2018-08-05 17:37:56.349640+0300 juicecats[1257:413123] [MC] System group container for systemgroup.com.apple.configurationprofiles path is /private/var/containers/Shared/SystemGroup/systemgroup.com.apple.configurationprofiles
2018-08-05 17:37:56.350959+0300 juicecats[1257:413123] [MC] Reading from public effective user settings.
→ applicationDidBecomeActive()
GfxDevice: creating device client; threaded=1
Initializing Metal device caps: Apple A10 GPU
Initialize engine version: 2017.1.3f1 (574eeb502d14)
OnLevelWasLoaded was found on LeanTween
This message has been deprecated and will be removed in a later version of Unity.
Add a delegate to SceneManager.sceneLoaded instead to get notifications after scene loading has completed

(Filename: Line: 380)

(lldb)

Hello again. I’m not sure what the issue was but this is a workaround that helped me build the game. When building the game from Unity, the first issue that came up in xCode was: error: ‘release’ is unavailable: not available in automatic reference counting mode. I switched it to No and tried to build. Now the player archive error came up and I was stuck for a few days trying to fix it. The noob me didn’t think that maybe the automatic reference counting is messing it up. I followed the accepted answer from this thread iOS - Disable ARC on XCode Projects - Questions & Answers - Unity Discussions and I managed to build the game with no visible bugs. I still don’t know why that error came up and if the game will have bugs because I didn’t fix that exact error but this is how I managed to build. Maybe someone will find this helpful in the future