Player is not authenticating - Google Play Games plugin for Unity not authenticating for android

I have the downloaded the plugin from GitHub - playgameservices/play-games-plugin-for-unity: Google Play Games plugin for Unity for android. Added all the ID’s in the project after importing the plugin. Written the script to authenticate the player as well provided the buttons to login, check the leaderboard, submit the score and achievements. Also published the game in alpha testing mode in google play developer console with a google+ group as test users.

We install the game from the opt-in link provided. The player is not authenticated even after we receive the window to login and the window which asks for access to our profile details. The loading indicator disappears after sometime with failure callback. We checked with debug logs. The authentication fails. We cross-checked with ID’s and Bundle ID. They are all correct. We tried with every versions of plugins from Still it fails. Any idea?

You can download and view the sample project from this link:-


I had the same issue with google play asking to sign in and then nothing happened after that in terms of opening the leaderboard or other services. In the debug log it was saying “ERROR_NOT_AUTHORIZED”.

It turns out that despite everything being correct in unity and google play, the issue was to do with the signature of the app, as I happened to have changed it from when I first created the game service on google play developer console.

For me, I went to Game Services > Linked Apps > Link to a new Android app

Fill out all the details the same, however when you “continue” to authorize the app, it will display a SHA1 fingerprint, it will automatically have this filled out, with the new fingerprint of the current APK uploaded. Once I published the game service with this new authorization, everything worked.

Did you ever get this fixed? I am running into the same issue.