Player Settings Empty

whenever I go to Project Settings > Player , I get an error on my console saying
NullReferenceException: Object reference not set to an instance of an object

and another one

IndexOutOfRangeException: Index was outside the bounds of the array
UnityEditor.PlayerSettingsEditor.OnEnable ()

I’m currently working on a project for an android build, and I’ve tried switching it back to a windows build just to test if my player settings would show up there but it didn’t.

I understand there might be something wrong with my Unity Files so here is a list of things I’ve done with it:

  1. I tried installing a different Unity Editor Version but my files won’t load properly so I switched back to what I am using (2022.1.20f1)
  2. I tried manually deleting my files in my installs folder, it didn’t have any effect on anything
  3. I also tried Reinstalling my unity editor from the Unity Hub

It’s been working properly and I’ve been seeing it before I tried switching to an ios build. So maybe something went wrong after I did that? I’m just not quite sure if that really is the case. If so, may I get some help figuring out how I can edit my player settings?

Hey, I had a very similar problem, but nothing was displayed when I entered Preferences. It turned out that the reason for the error was a duplicate file called Newtonsoft.Json.dll that accidentally ended up in my project. After removing it everything worked fine

Hey, did you ever find a resolution to this?

I don’t think I have. I remade the whole project from scratch. I made a new unity project, did everything again, and copied necessary assets and inputs from the old one.