Playing alembic sequence from timeline

Hi guys i’m trying to import alembic animations files but i cannot find any tutorial on how to play it from the timeline editor for cinematic. Anyone have an idea please? Thanks

no answer :frowning:

Are you using the alembic custom track from here?

I am interested too, I having the same trouble. I checked your link but I didnt understand how use those scripts. Please could you tell how to make it?
Thanks

step one: import an alembic file using the importer (just drop an abc file in assets directory or manual import throught “Import New Asset” menu item"). Make sure that the importer’s setting “Import Mode” is set to “AutomaticStreamingSetup”
step two: drag/drop imported prefab into scene.
step 3: create time line asset, and drop it in the scene.
step 4: select the timeline object and open the timeline editor
step 5: click “add” button and select utj.Alembic.Alembic Track
step 6: right click on track and select add alembic shot asset clip
step 7: select added clip, in inspector of the clip, “Stream Player” d&d the alembic prefab from the scene onto this field

from here, you should now be able to scrub the animation from the timeline and see the scene update your alembic asset.

3 Likes

Thank you so much Jason, Its works!

Seems I didnt step 7 :stuck_out_tongue: I thought was automatically assignation.

I using timeline to “fix” alembic lag. There is kind delay between animation joint and alembic (seems There not goes same FPS), I thougth I try to control FPS from timelime editor for each system (alembic and joints) Is a crazy idea or has sense?

Many thanks for your help

Thank you, problem solved :slight_smile:

Thanks for this - I have my alembic file working in the editor with timeline, but I build it I’m running into a plugin error:

Plugin ‘abci.dll’ is used from several locations:
Assets/UTJ/Alembic/Plugins/x86/abci.dll would be copied to /abci.dll
Assets/UTJ/Alembic/Plugins/x86_64/abci.dll would be copied to /abci.dll
Please fix plugin settings and try again.

If I remove/rename one of the plugins, the .dll reference is shown as missing in Xcode. It appears to need both but runs into this conflict. Has anyone had a similar issue?

(my architecture’s Universal and the scripting backend is IL2CPP)

Sorry to ask what is likely a dumb question, but where is the “importer’s settings?” When draging in an abc or going “Import new Asset” I am missing something.

Thank you,

Max.

Just wanted to clarify further:

I can seem to do every other step here fine. It’s just the “automatic streaming setup” that I am unable to find. I believe it should look like this image:

Which is from the github page: com.unity.formats.alembic/Screenshots at main · Unity-Technologies/com.unity.formats.alembic · GitHub

However the only thing close I can see is on the .abc file imported into unity from the inspector. The options there read as:

Normals: Compute if missing
Tangents: Compute
Camera Aspect Ratio: Camera aperture
Scale Factor: 0.01
Swap Handedness (checked)
Interpolate Samples (checked)

Mesh Options expanded menu
Swap Face Windin (unchecked)
Turn Quad Edges (unchecked)
Import point Polygons(checked)
Import Line Polygons(checked)
Import Triangle Polygons(checked)
Components expanded menu
Import Xform (checked)
Import Camera (checked)
Import Poly Mesh (checked)
Import Points (checked)

Time range

If I can find that menu for the mode to be set to AutomaticStreamingSetup, I’m sure it will work. Everything else has allowed me to at least play the game, exit out, and find that the mesh has changed position/rotation letting me know that the cache is affecting the mesh, just not streaming.

Save me unity answers, you’re my only hope.

you may click clone this plugin. it not work for me ether.
click download “Latest package: AlembicForUnity.unitypackage” in README panel.
or follow this video

hope it work !

its such a Mission lol

NOOO! 90mb… NOOOO! there is no other way to play my animations… IM DOOOOOOMED

Has anyone here been able to get their .abc animations to show up on their Android after ‘Build and Run’??

Hey,

Alembic supports only Windows OSX and Linux stand-alone build targets since it contains native dll’s that do the heavy lifting.

Thank you @vladala . Is there any way to convert my fluid simulation file, so it can work with Android? Do you know if this is something that is being worked on by Unity as a future product enhancement?

Sorry, but I don’t know of things that you could do today to make it work on Android. The only way to see that happening is if we implement a native geometry format inside unity that would support all platforms (no work scheduled for that currently)

1 Like