Please explain me some stuff about Editor packaging

I might be missing something obvious, but 2019.4.40f1 (likely more, 39f1 definitely too) (https://download.unity3d.com/download_unity/ffc62b691db5/LinuxEditorInstaller/Unity-2019.4.40f1.tar.xz) seems to lack the executable - it only has the debug symbol blob.

On the other hand, it contains the static curl lib...what is that for ?

The "Editor/Unity" file in that archive is the executable:

9560413--1351750--upload_2024-1-3_13-22-7.png

It works for me:

tautvydas@DESKTOP:~/Downloads/unity-2019.4.40f1/Editor$ mkdir ~/Projects/UnityProjects/New\ Unity\ Project\ \(211\)
tautvydas@DESKTOP:~/Downloads/unity-2019.4.40f1/Editor$ mkdir ~/Projects/UnityProjects/New\ Unity\ Project\ \(211\)/Assets
tautvydas@DESKTOP:~/Downloads/unity-2019.4.40f1/Editor$ mkdir ~/Projects/UnityProjects/New\ Unity\ Project\ \(211\)/ProjectSettings
tautvydas@DESKTOP:~/Downloads/unity-2019.4.40f1/Editor$ ./Unity -projectpath ~/Projects/UnityProjects/New\ Unity\ Project\ \(211\) -batchmode -quit -logfile -
CreateDirectory '' failed:  (current dir: )
Unity Editor version:    2019.4.40f1 (ffc62b691db5)
Branch:                  2019.4/staging
Build type:              Debug
Batch mode:              YES
System name:             Linux
Distro version:          #1 SMP Wed Mar 2 00:30:59 UTC 2022
Kernel version:          5.10.102.1-microsoft-standard-WSL2
Architecture:            x86_64
Available memory:        15986 MB
<REST OF THE LOG SPAM>

That looks like a bug in our build scripts, it probably got copied in accidentally. It should not be there on newer versions.

...my bad, I should have checked a thing.
The content on the archive is correct, but the executable wasn't installed by the web setup:
UnitySetup-2019.4.40f1: 418728 B, sha256 6bd3fe1c924882c29c09314bc51eacfcc412d5c591578ed4d0b07fc143e798af

Content of the installations top dir:

Data
cef_100_percent.pak
cef.pak
libcef.so
libcurl_a.a
libembree.so
libOpenCL.so
libOpenCL.so.1
libOpenCL.so.1.0.0
libpdf.so
libtbb.so.2
UnityHelper
Unity_s.debug

That is most unusual, did you install it using Unity Hub? I don't think we have a "web installer" for Linux.