Pointlight cubemap not working on all computers

I have a pointlight with a cubemap. The cubemap works correctly on one of the computers I am testing on, but not on the others. On the computers where it doesn’t work, it acts as if is there is no cubemap at all.

The hardware set up is the same on all the computers that I am testing on.

I have 4 computers:

  • A. cubemap works
  • B, C, D cubemap does not work

There are some differences:

  • A. Unity Pro installed. OpenNI drivers installed for use of the Kinect, if it can not find OpenNI it will not try to initiate the Kinect features, the rest of the program is unaffected.
  • B, C, D. No Unity Pro, no OpenNI drivers.

Does anyone have some suggestions on what could cause this problem? I am going to try and install Unity PRO and OpenNI drivers to see if this is what causes the problem, I will update this post if that solves the problem.

It works on Unity PRO only!

I fixed it.

I fixed it by adding ‘UnityGraphicsQuality_h1669003810’ with value ‘5’ to HKEY_CURRENT_USER\Software[Company name][Program name] in registry.

Apparently the graphics quality matters for rendering cube maps. That fixes it.

Note: I had the resolution/graphics quality dialog disabled on startup, so that explains it that it takes the setting out of registry.

And I found another solution: change render mode to ‘important’ of the point light. This makes it independent of the graphics quality.