Polygon Collider 2D isn't allowing me to edit points

When you add a 2D Polygon Collider Component, there is a edit collider button, and when I press it, it doesn’t do anything, i can’t edit, add, or delete any points. If I click, after clicking it, it selects another object, and no “green square to edit the points” is shown.

-I am not in debug mode, if you think that’s the problem.
-I have also tried scripts to manually edit the points, but we are talking about 250+ points, so that’s not going to happen!

Any help is appreciated,

Thanks!

This can also happen if the object to which the polygon collider is attached is either rotated or scaled - it seems the editor gizmo for 2D colliders expects objects to have a scale of (1,1,1) and a rotation of (0,0,0).

Try setting the object’s Pos Z to 0, if it isn’t already.

For me it solved the problem by zooming out the scene view. Remember in some case you need zoom out very much . this is an bug and i reported.

use this:

PolygonCollider2D col;

public IEnumerator Example(int i,Vector2[] v2)
{
        col.SetPath(i, v2);
        yield break;
}

Activating Gizmos will help.

It may not be relevant now, but also when you are in debug mode trough inspector you cannot edit points.

This is still an issue in 2023…