Possible bug: Static Batching breaks UV mapping

I’ve just filed a bug (745664) and I’d like to know if anyone has experienced the same, and if that’s the case, what has been your workaround.

Windows standalone player breaks UV mapping for some objects marked as static. In the editor everything renders perfectly, also in the Game window. But building and running the Windows Standalone shows the stripes in the picture. UV mapping seems to be broken for some polygons.

It happens when two objects with the same material are batched together, and usually with objects with a high vertex/triangle count. I created the FBX files with 3DStudioMax, in case that gives some insight. I found it in early versions of Unity 5 but it is still present in 5.2.2p2.

So far, what I’m doing is uncheck Static for the elements where I see the problem, but then I lose some performance.

I would appreciate your comment if you have experienced the same. Thank you!

This thread in the forum could also be related.

Ok, I have some discoveries…

It happens when the UV coordinates in the objects are big.
Moving the UV maps to the center (reducing the coordinate values), fixes the problem.

I still think it’s a problem in Unity that should be fixed, but it has a workaround.

Cheers.

I have the same problem, i filed a bug too but i have no answer, at the moment i have to disable static batching.