Post Processing Bloom Issue in Vision Pro Full Immersive Mode (URP)

Hello,

I am developing an application using Unity’s URP for Vision Pro Full Immersive mode and have encountered an issue. When I enable the Bloom effect in Post Processing, a red area appears on the left side of the screen.

Here are my environment details:

  • Unity version: 2022.3.33f1
  • URP version: 14.0.11
  • VisionOS XR Plugin: 1.2.3

I have already tried the following methods, but the problem persists:

  1. Updated URP and Vision Pro SDK to the latest versions.
  2. Adjusted Bloom effect parameters.
  3. Checked and updated graphics drivers.
  4. Tried using the MK Glow plugin, but it not working too.

Has anyone encountered a similar issue or found a solution?

Thank you!

1 Like

Post Proccess is not support now
SupportedFeatures

Just for clarity, those restrictions are for PolySpatial (MR mode, bounded or unbounded, using RealityKit). They don’t apply to full immersive (VR/Metal) mode. VR/Metal mode does support post-processing effects, though I’m not sure about the issue with this particular bloom implementation.

1 Like