Post Processing Not working, tried everything I can think of.,Post Processing not working whatsoever.

I’ve looked around for quite a few hours and none of the tutorials or any page has helped me so far. I have tried all I can think of, and this has worked before so I don’t understand what the problem may be.

This is how it looks right now, FXAA is on, but the lines are just as jagged as they are without it on, and the other settings don’t seem to change that whatsoever.

The red cube has an emissive material, but none of the bloom works, I tried using color grading to make everything grey, just to see if it works, which it didn’t either. Yes, you may have noticed the bloom intensity is at 0 and I tried changing it to no effect, so turned it off again.

I’ve tried multiple different things said by different people, watched tutorials on how to fix it, including what I think was Unitys own tutorial and that didn’t work either.

I tried having the Post Process Volume on a different object and having it either in a specific area or global, none worked.

I tried changing the Layer the camera was on to the same as the Post Process layer, didn’t work.

This is also the second project that it doesn’t work on, first tried it in my project where I have really wanted it for a while. I have updated Unity Hub and tried the newest, and older versions of Unity, nothing’s worked so far. (2020.2.1f1 Personal and 2019.1.14f1 Personal to be specific.)

I really need some help, since a lot of my game would look loads better with effects, thanks in advance!

Found out the problem an hour or so after, forgot I had the HDRP on for the project, and there are specific Post Processing effects for that render pipeline, took a while, but I managed to fix it, thanks for the help though!

For the 20th time ever… (sorry, not your fault. This question is quite common).


First:

  1. Assign a post process layer to your camera.
  2. Create a new layer (as you’ve done already) as the volume blending layer

Next:

  1. Create an empty gameObject (to keep things organised)
  2. Assign a post process volume component to it
  3. Set to IsGlobal (or not, if you know how it works)
  4. Assign post process profile to it, and give correct settings
  5. Make sure to set that gameobject’s layer, to the layer set in the post process layer component on your camera.

You should start to see some effects. Hopefully… @lukasskaane