Post Processing Not working

Im trying to complete the John Lemon’s Haunted Jaunt tutorial for a class project but im stuck on the camera section. No post processing is being applied. I set the camera’s layer to “PostProcessingVolumes”, I set the post process layer component’s layer option to “PostProcessingVolumes”, and I set the “GlobalPost” Object’s layer to “PostProcessingVolumes”. Ive followed the instructions to a T, and I have no idea why nothing is working. Im using unity version 2020.1.6f1. Im also getting a bunch of errors that ill include in the images. if possible, id like to not open any scripts as they still havent added vs to these computers so ill have to use notepad.

172365-capture3.png

Something to note, these are 2 separate images that both contain the same component. The camera does not have 2 post process layer components.

More Images

172367-capture5.png

Solution


I believe that because you have two post process layers on your camera, the camera is getting confused as to which layer/s it needs to apply the effects on or something along those lines. The camera doesn’t have to have the same layer as the Post process volume as well. (Just something to note).


A lot of beginners struggle to get started with using the post processing stack, so I’ve listed some steps for others who might find this post to get started. Not for you @Sethery88 since you clearly know how to set this up.


How to apply post processing


So essentially, post processing is the processing of an image taken by a camera and shown instead of the pre-processed image.
This may add effects such as bloom or a vignette etc. Therefore, since the processing is done on the Camera, a camera setup is needed before proceeding.


The camera doesn’t need to have a specific layer. Don’t set it to the post process volume layer. However, the Camera needs to have the component called Post Process Layer to specify which layer of objects it should apply the effects onto. The trigger should be this camera and the layer should be the layer of the object with the post process volume.
You should only have one Post process layer per camera.


Next, the post process volume is another component that specifies what effects to generate. This should normally be on an empty GO to tidy up your scene, with the layer that you specified in the post process layer on your camera. Then, you need to attach a post process profile to the slot called profile, which can be created by hitting ‘new’, which finally allows you to add your desired effects. There are a lot of effects you can play around with but at this stage, you should be able to see them in real-time, being applied to your scene and in-game.

This remains unresolved. I am having the same problem with Post Processing in Unity 2020.3 LTS. I have gone over and over several tutorials, followed directions in documentation to a T and it is still not functioning. Doing a Standard Render Pipeline build using Windows. I’ve tried deleting the camera, creating a layer for the empty PP volume in the Hierarchy, to no avail. It simply will not work. I appreciate all of the input people have given here, but if it doesn’t work by following the documentation, and nobody can actually resolve the problem beyond that, then what is going on? I have implemented PP in Unity 2019 with very little trouble. This simply seems not to work.

Check the console. If you’re seeing an error about Lut3dBaker and the Kernel, you may just need to update the post-processing script through the package manager.

Maybe I’m the only one but it took me a long time to realize I needed the actual objects in the scene to be on the Post Processing Layer I made…