Post-Processing Stack V2 has no effect

I have the Package installed completely correctly, volume and layers are set up as they should be and are on the post-processing layer, I’ve made sure it’s hooked up correctly in Project settings, I’ve mirrored dozens of other peoples settings, created blank projects to test if they worked then (they did), and I’ve spent almost 8 hours trying anything to get any perceivable difference in the game or edit window. I’ve re-installed the project and Unity multiple times, switched versions, and still nothing. I’m currently using 2019.30f5 but I’ve made a blank project as well and the post-processing effects work fine on every version including the ones I’ve test my game on.

One reason for this to happen to many people (including me) may be that the Universal Render Pipeline (short URP, previously LWRP) does NOT support the Post Processing Stack package from unity.

Quote: "The Universal Render Pipeline (URP) includes its own implementation of post-processing, so you do not need to install any other package. URP is not compatible with the post-processing version 2 package. "

URP ships with it’s very own PostProcessing Stack already included. The tricky thing is that once you have (wrongly) added the package. You will find yourself stumped that even by following the tutorials no effect whatsoever will be shown. You will have to uninstall it and follow the Manual on the URP page here: Post-processing in the Universal Render Pipeline | Universal RP | 7.1.8

Here is what worked for me:

  1. Uninstall the Post Processing Stack Package (Window > Package Manager)
  2. It will leave a define “UNITY_POST_PROCESSING_STACK_V2” in your Scripting Define Symbols (Project Settings > Player > …), remove it.
  3. Under “Project Settings > Tags and Layers” add a new layer. Name it something like “Post Processing”.
  4. Create new volume with “GameObject > Volume > Global Volume”
  5. Select the volume in your scene and under “Profile” press the “New” button.
  6. Click “Add Overlay”, choose Vignette and put the intensity to 1. I just chose Vignette here because it’s easily visible. You can of course choose what ever effect you like.
  7. Change the LAYER of your volume object to the “Post Processing” layer you created earlier.
  8. Now select your CAMERA and under ENVIRONMENT > VOLUME MASK make sure your “Post Processing” layer is checked. It does not matter what layer your camera is on as long as the volume mask is set up correctly to include the post processing layer(s).
  9. Done, you should now see the vignette. Be aware: this is the process for URP projects. It’s not universally applicable.

Took me a while to figure out. I hope it will help others.