PostProcessPass render pass will not execute.

Edit: This is an old error for me, I don't remember the details and am unable to reproduce this.


Hello,

I'm receiving this error with no further information after upgrading to the beta. I think the following error is just referring to shaders that were broken during the upgrade, but, how do I find them? Everything looks fine as far as I can see.

I'm using URP, and have upgraded from 2021.1.10f1 to 2021.2.0b2.

Missing shader. PostProcessPass render pass will not execute. Check for missing reference in the renderer resources.
UnityEngine.GUIUtility:ProcessEvent (int,intptr,bool&)

1 Like

Hello,

do you found a solution? I have the same problem.
I get the error in a new empty scene. I don't know what resource was broken during the upgrade.

Same. Anyone a solution?

Same error (2021.2.0f1). using URP, Android target.

We are not yet aware of this issue. Could you submit a bug report? We will look at it asap.

Bug submitted : Case 1376316

This one is a wierd one. I've spent a couple of hours trying to clear down to a repro case.

It's something to do with the URP pipeline settings asset - in the project submitted with the bug report, I have a clean URP asset (newly created in 2020.2.0) and my current project URP pipeline asset (created waaaay back, probably 2019 but possibly 2018). Selecting the "new" URP pipeline asset - no errors. Selecting my "old" URP pipeline asset, and the errors appear (upon loading project, and building, etc).

It's definitely not as simple as "create a new pipeline asset" to resolve though - I've tried that in my main project, and I'm still seeing the errors.

Feel free to DM/mail if I can provide any more deets.

2 Likes

It's actually a simple fix, though it needs to be patched out, but just delete original, create a new one, and reassign everything you had in it, once you create a new post process data and reassign it to the render pipeline that should remove the error, or at least it did for me

This is now in the issue tracker:
https://issuetracker.unity3d.com/issues/postprocesspass-render-pass-will-not-execute-error-thrown-in-console-when-upgrading-urp

2 Likes

I had this error upgrading Viking Village to 2021.2.2f1. Problem was PlanarReflectionsPostProcessData didn't have a LensFlareDataDrivenPS field and that caused the missing shader error to occur in MaterialLibrary.Load() in PostProcessPass.cs

2 Likes

Has anyone figured out how to find the broken shaders/files?

Wow that was annoying and I wish some of the responses here weren't so callously vague.

I'll try to be as specific as possible so that other people can be less frustrated.

I had generated a "CustomPostProcessData" in a previous version (this can be done via Create -> Rendering -> URP Post Processing Data). In my case, I wasn't even using it, but it looks like it's corrupted/not-migrated-properly so I ended up removing it and creating a new one.

Then follow these steps:

  • Go to your Render Pipeline asset
  • Go to each one of your Renderers in the Renderer List
  • Disable Post-Processing (for now and this may not be necessary)
  • Once done, you shouldn't see anymore errors
  • Go back and enable Post-processing and select the newly created "CustomPostProcessData" asset. If you select the old one (instead of removing it) you'll see those pesky errors again.

Hope that helps!

17 Likes


2021.2.15 -> 2021.2.16 caused the issue for me.

wheee09's well outlayed solution was spot on and resolved the issue.

1 Like

It seems the URP post-processing data object gets its shader parameters updated every few versions. I just ran into this issue when upgrading from 2021.2.8 to 2021.3.0. The missing shader parameters this time turned out to be scalingSetupPSand easuPS.

The fix was as wheee09 described above. Remove the existing URP PostProcessData object, create a new one, and update any URP renderers to reference the new one.

It would be nice if the Unity editor handled updates like this more gracefully.

4 Likes

Just ran into this today too. Deleting our custom one and just using the one URP seems to generate worked for us.

1 Like

This was me today. Thank you @wheee09 kindly

As others have mentioend - a small request for Unity to fix editor handling of this.

2022.2.5f and the problem is still there.

I got same issue and the way I solved is in this GIF below:

https://gyazo.com/a0e4a70e7fc940d20b8f24edbc317945

1 Like

I have solved this problem. The shader referenced in the ScriptableObject of PostProcessData in the project is missing and needs to be re referenced.

Same, after updating Unity to 2023.2.7, post-processing not working