Pre baked shadows in Unity 5??

I can’t seem to find a way to bake all the shadows in my scene, so I can remove the actual shadows to increase performance and I tried doing the same like older Unitys but it just won’t work in Unity 5! If I click build and it finishes loading, there are still no baked/painted shadows! I did everything right and it worked in every older version. Is there any way to get the old simple baked shadow feature back??

Are you setting your lights, ambient gi, and light tab settings to bake before building?