Prevent third person controller seeing through objects and terrain

Hi all,

I am currently using the third person controller which ships with unity, and is working fine except for the problem stated in the title. I have researched this for some time, and people have said changing the clipping plane on the main camera should do the trick…but it does not work for me; and this also makes the movement really jittery.

Could someone please point me in the right direction please…Thanks!

Try this camera controller: http://wiki.unity3d.com/index.php/SmoothFollowWithCameraBumper

Or choose from a list of options: http://wiki.unity3d.com/index.php/Scripts/Controllers

Or write your own using 3DBuzz’s tutorial: http://www.3dbuzz.com/forum/threads/186940-Unity-Creating-a-Custom-3rd-Person-Character-System-Drop-ONE