Preventing culling for particle systems?

Hi everyone,

I’m having a pervasive problem where my camera is positioned ‘inside’ of complex a particle system containing several million particles (completely enveloping the viewer). It works great, except that occasionally the particle system is erroneously culled from the view (resulting in the particle array being cleared, and IsAlive becomes FALSE).

I need to prevent the particle system from being culled, or fix the culling behavior.

I’m using Unity 4.1.2f1.

Thank you for you help.

With kind regards,


Put the particle system on a child object to camera, set it’s position 5 units in front of the camera, and then change from Local to world coordinates in PS component. Works fine.

Hey everyone, just in case you were confused as I was with your particle system. There’s a setting in the inspector that helped me. Thanks to this question and the answer above for helping me even know what I was looking for after troubleshooting for hours. My rock and dust particles wouldn’t emit if the particle system wasn’t in view by a camera, even if I turned into it. It was freaking me out because it even knew when the scene view camera saw it or not. Didn’t see anyone else ask this question so I’ll just drop my solution here…

In the Inspector under the Particle System component, there’s a dropdown under “Culling Mode”. I just switched it from “Automatic” to “Always Simlutate”. So simple it made me palm my head… but hope it helps someone :smiley:

Version 2018.3.0f2