Prewarm doesn't prewarm correctly

I want to make a starfield particle system for a space shooter game. Obviously, I need my particle system to prewarm so that the starfield looks like it has always been there. But for some reason Unity won’t prewarm my particle system completely

note that after a while, the starfield does fill the entire screen correctly

My understanding is that the particle system is prewarmed as though it had been running for a certain amount of seconds. I thought that amount was calculated based on the maximum lifetime of the particles, but apparently it’s not.

So the question is:

  • how does Unity decide how many seconds it prewarms

  • how can I configure my particle system so that it prewarms long enough for my starfield to fill the screen

  • if it can’t be configured in the particle system settings, how can I force the particle system to prewarm for a custom amount of time (through code I guess)

BTW here are the settings for my particle system

alt text

Ok I figured it out. I had to increase the “duration” of my particle system.

this leaves me with another problem though because there was a very good reason for me to have set that duration to 0.2, which was to prevent a wavelike effect with regards to particle size. Guess I’ll have to solve that issue in another way.

I accepted already my fate not not to have prewarmed particles. Then I changed Simulation Space from world to local and it worked!