Problem : camera is shaking


I’ve just downloaded Unity, and followed the tutorial in order to make my first scene.
The problem is that i have some “shaking” indesirable effect.
Indeed, when moving around the scene, or play it with the fps controller, my screen is continually shaking and it’s impossible to try anything in this conditions.

If you need i can maybe take a video of this phenomenon but i didn’t do anything except create two cube, one for the plane, another one just to put on the plane, a light, and the fps controller on the scene.

Thanks for responding.

edit : i’m running on Windows 7.

in the inspector under Character Motor SCript is a setting Steep perp Amount: try puting that at either .1 or 1.0 i can’t Remeber which it was.

Set it as a child of the main camera, that tends to work. If it doesn’t remove the colliders from the camera.

Hey, I had a similar issue, so I found that the “Step Interval” option could make the camera shake. So, delete the main camera, and then increase the step interval for the camera to stop shaking.

I noticed a camera shake today and I can second that the accepted answer to this has to do
with camera bounds (in my case).
When your camera get’s to certain point:
(example: the polygon collider I have surrounding my scene (as bounds)) it jitters a bit.

  To catch this, play your scene and run along a flat surface 
  and make sure the camera is selected. 
  Watch carefully as your player's transform stays the same on the y axis (2D  platform game) 
  and if it changes then that's where your camera jitters. Look at the bounds 
  (if you have any set on the camera) and either increase the bounds to the left or right. 

Another reason could be an uneven terrain when having the camera set on follow player. This could cause an undesired up-down shake. A quick fix could be to dampen the movement of the camera, so that it doesn’t follow the player as fast.
Hope this fix issues for some! Best of luck.