Problem loading dll for Universal app 10

I am working on a universal app for windows 10 . When I place in my assets a external third party dll this message appears: Why this happen?

Blockquote
Unhandled Exception: System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
at System.Reflection.Assembly.GetTypes () [0x00000] in :0
at Mono.CSharp.RootNamespace.ComputeNamespaces (System.Reflection.Assembly assembly, System.Type extensionType) [0x00000] in :0
at Mono.CSharp.RootNamespace.ComputeNamespace (Mono.CSharp.CompilerContext ctx, System.Type extensionType) [0x00000] in :0
at Mono.CSharp.GlobalRootNamespace.ComputeNamespaces (Mono.CSharp.CompilerContext ctx) [0x00000] in :0
at Mono.CSharp.Driver.LoadReferences () [0x00000] in :0
at Mono.CSharp.Driver.Compile () [0x00000] in :0
at Mono.CSharp.Driver.Main (System.String[] args) [0x00000] in :0
Missing method .ctor in assembly C:\Users\xxxx\Documents\Unity 3D\Test\Assets\Resources\RobotStudiodll\ABB.Robotics.RobotStudio.dll, type System.Runtime.Versioning.TargetFrameworkAttribute
The class System.Runtime.Versioning.TargetFrameworkAttribute could not be loaded, used in ABB.Robotics.RobotStudio
Can’t find custom attr constructor image: C:\Users\xxxx\Documents\Unity 3D\Test\Assets\Resources\RobotStudiodll\ABB.Robotics.RobotStudio.dll mtoken: 0x0a0005c5

Finally I solved it just adding in my code and adding it in universal app aplication compiled for .netcore
#if WINDOWS_UWP
using mydll
#endif