Problem parsing package with API level 29

I was ready to publish my game I have been working on for a while now to the Google Play Store. It was working great. I uploaded the APK and got the error API level 29 or higher required. So I changed my API level to 29 installed the newer version and got the build to work. It finished with no errors but when I tried to install it on my phone to test I got “There was a problem parsing the package”. The things I have tried are using API level 30. Using Android Studio to install the SDK. Changing from unity version 2019 to 2020. I have also tried various combinations of these things. I also can’t seem to find anything about this anywhere. Any help is greatly appreciated!

Did you change the Minimum API Level or the Target API Level to 29?

Google is only requiring that you change the Target API Level to 29 or higher.

Try leaving your Minimum API Level at the minimum available, and changing your Target API Level to explicitly ‘API level 29’ instead of ‘Automatic’, since ‘Automatic’ chooses only the highest installed version, which may be lower than 29 for you.

I have been trying to download the amazon app store from chrome but when ever i try installing it get an error saying there was a problem parsing the package. I have my allow unknown sources check box on but its still giving me problems. Help please!