Problem with adding textures to imported models (C4D)

Im trying to import an empty basic model from Cinema 4D (exported in fbx-format). Its just a cube, nothing else (no textures, no nothing).

When importing the fbx-file of this cube into unity, I drag a texture (for instance grass) on top of it. Looking in the inspector all seems to be fine: the correct texture is selected, Shader is diffuse, tiling is 1 and 1, and offset is 0 and 0.

But looking at the actual model its just plain green without any details of the actual texture.

When creating an equally sized cube from within unity and adding the same texture, you can see the details on the actual cube.

So, did I miss something in importing the cube (Ive done nothing else but to import it)? Or is there something else Im missing?

Daniel I have fixed it in Blender. The reason was the "UV tex" attribute that i was not setting to the newlly created object. Try to find something similar in your CAD. It's in the Mesh setting. What the attribute do ? Read here: http://wiki.blender.org/index.php/Doc:Manual/Textures/UV

I have the same problem with blender and 3dmax object. Can someone help us?

A wild guess: Look at the FBXImporter component on your model, and check if your Scale Factor is set to 1.

I think the scale-factor was to blame in my case. When zooming into the texture all the way (just before going trough the material) I noticed that there were the details of the texture. In other words, the imported model was huge in comparison with the textures. Thanks for setting me straight on this :)

I was having this problem too. What fixed it for me was when I exported my cinema file as a 3ds file. It's as if unity couldn't grab the UV information directly from cinema but has no problem grabbing it from 3ds.

I was having the same problem, truly frustrating but messing around i discovered that if instead of importing the FBX just import the C4D file and that fixed the texture problem for me now looks great
hope that works, keep making cool games :wink: