i am trying to put ads in my video game but when i test it the console show me this message:

ResolutionException: Cannot find candidate artifact for[10.2.4]
Google.JarResolver.PlayServicesSupport.GetDependencies (Google.JarResolver.Dependency dep, System.Collections.Generic.List1 repoPaths) Google.JarResolver.PlayServicesSupport.GetTransitiveDependencies (System.Collections.Generic.Dictionary2 dependencies, System.Collections.Generic.List1 repoPaths) Google.JarResolver.PlayServicesSupport.FindMissingDependencyPaths (System.String destinationDirectory, System.Collections.Generic.Dictionary2& dependencyPaths, Google.JarResolver.ExplodeAar explodeAar)
GooglePlayServices.ResolverVer1_1.DoResolution (Google.JarResolver.PlayServicesSupport svcSupport, System.String destinationDirectory, Google.JarResolver.OverwriteConfirmation handleOverwriteConfirmation, System.Action resolutionComplete)
GooglePlayServices.PlayServicesResolver.Resolve (System.Action resolutionComplete)
GooglePlayServices.PlayServicesResolver.AutoResolve ()
UnityEditor.EditorApplication.Internal_CallUpdateFunctions () (at C:/buildslave/unity/build/artifacts/generated/common/editor/EditorApplicationBindings.gen.cs:197)

how can i solve it, thanks

  1. Download the latest play-services-resolver package from :
    GitHub - googlesamples/unity-jar-resolver: Unity plugin which resolves Android & iOS dependencies and performs version management (it will be the file ending with .unitypackage)
  2. Backup your Unity project
  3. Remove the ‘Play Services Resolver’ folder from your unity project
  4. Import the package you downloaded
  5. Say yes to the prompts asking you to change the settings
  6. Clear your console of all messages
  7. Go through menu: Assets->Play Services Resolver → Android Resolver → Resolve Client Jars

There is an additional step someone mentioned in the comments:

Assets > Play Service Resolver > Version Handle > Update

Should be fixed

I found this:
“Go to the file in your project Assets/GooglePlayGames/PluginVersion.cs, inside change the PlayServicesVersionConstraint to “10.2.1” (the default value is"10+”)."
And Unity say Resolution Complete!

I have some your problem

Same error here. Last unity version, 5.6.0f3. Admob and play-services unity latests versions…

Same error too …
Unable to find dependency[10.2.4] in paths ($SDK\extras\android\m2repository, $SDK\extras\google\m2repository, $SDK\extras\android\m2repository, $SDK\extras\google\m2repository).

I was also having this error, I believe, when I was using 5.6.0b. I ended up switching to Unity Ads, only to realize there is not near enough variety of ads to garner many clicks. I would like to see this issue resolve, and don’t know where to start…the call for the ad simply didn’t work. The error message was similiar but I cannot confirm how similar. I’m only chiming in in case it is a bug that many of us are experiencing…

have someone solve the problem ? i have the same i dont know what i have to do.

This did the trick and hey > great example of someone giving us exact step by step instructions!

My ads are now appearing in the builds!!


Worked for me! Thanks

Thanks Budy issue resolved

thank you ! is work

You can use other plugin such as,witch include all jar files and more easy to use