Problem with GooglePlayServicesResolver

Hello, I have a project that was in 2018.3.3 and I upgraded it to 2018.3.8, which is the latest version.
But for some reason, PlayServicesResolver didn’t get updated properly, because it throws this error message every frame (stacking 999+ in the editor console) (the important part is the highlighted text, the other is the full log):

ToolNotFoundException: jar not found, C:\Program Files\Unity\Hub\Editor\2018.3.3f1\Editor\Data\PlaybackEngines\AndroidPlayer/Tools\OpenJDK\Windows references incomplete Java distribution.
GooglePlayServices.ResolverVer1_1.ShouldExplode (System.String aarPath) (at Z:/tmp/tmp.mz1RZCSjez/third_party/unity/unity_jar_resolver/source/PlayServicesResolver/src/ResolverVer1_1.cs:1513)
GooglePlayServices.ResolverVer1_1.LoadAarExplodeCache () (at Z:/tmp/tmp.mz1RZCSjez/third_party/unity/unity_jar_resolver/source/PlayServicesResolver/src/ResolverVer1_1.cs:256)
GooglePlayServices.ResolverVer1_1…ctor () (at Z:/tmp/tmp.mz1RZCSjez/third_party/unity/unity_jar_resolver/source/PlayServicesResolver/src/ResolverVer1_1.cs:220)
GooglePlayServices.PlayServicesResolver…cctor () (at Z:/tmp/tmp.mz1RZCSjez/third_party/unity/unity_jar_resolver/source/PlayServicesResolver/src/PlayServicesResolver.cs:624)
Rethrow as TypeInitializationException: The type initializer for ‘GooglePlayServices.PlayServicesResolver’ threw an exception.
System.Reflection.MonoCMethod.InternalInvoke (System.Object obj, System.Object parameters) (at :0)
Rethrow as TypeInitializationException: The type initializer for ‘Firebase.Editor.XcodeProjectPatcher’ threw an exception.
UnityEditor.EditorApplication.Internal_CallUpdateFunctions () (at C:/buildslave/unity/build/Editor/Mono/EditorApplication.cs:200)

I tried deleting all PlayServices files in my project and downloading the latest ones, and also uninstalling both Unity & Java JDK, and reinstall it all. Same problem…

Does anyone know how to fix this?

Thanks!

Alright, solved it. I had to open Regedit and go to “HKCU\Software\Unity Technologies\UnityEditor 5.x” and edit the version property, which, in fact, had not been updated and was still 2018.3.3f1. After changing it to 2018.3.8f1 and restarting the PC, it was fine.

@unpuzzlebarcelona How do u edit version property? I have the same problem.

Greetings from Spain.