Problem with my tweaked rigidbody physics impact sounds script

So I edited this old script from here: [Unity 4] Impact sounds for falling physics objects (JavaScript) - YouTube , to fit Unity 5 and added random and soft impact sounds, but the sounds play like its a 2d game. They don’t play on the rigidbody, but instead are heard in full volume. I don’t know how to explain it. It just like plays right in to your ears at full volume, doesn’t matter if you’re far away from that object who fell to the ground.

Here’s the JS script, you need to attach it to a rigidbody by the way:
`
#pragma strict

var impactSounds : AudioClip[];
var softImpactSounds : AudioClip[];

function OnCollisionEnter (hit : Collision)
{
    var randClip = impactSounds[Random.Range(0, impactSounds.Length)];
    var randClipSoft = softImpactSounds[Random.Range(0, softImpactSounds.Length)];
    if(hit.relativeVelocity.magnitude >= 5)
    {
        GetComponent.<AudioSource>().PlayOneShot(randClip);
    }
    if(hit.relativeVelocity.magnitude < 5)
    {
        GetComponent.<AudioSource>().PlayOneShot(randClipSoft);
    }
}

`

What did I do wrong? Thanks in advance.

You have to set spacialBlend parameter on the audio source to 1.0 before playing the clip.