Problem with rotating object

The script is fine, worked before but suddenly stopped working. Even works completely ok with other or any new project scenes but not working with the project i am working with. Funny thing is that if i delete all the scenes, models, objects, scripts and all other assets and just keep the rotating script and any object like a cube to be rotated, still it doesn’t work. Really can’t help myself to get off the problem. Thanks in advance.

I am happy to let you know that i solved the problem myself. Each scene requires Time.timeScale = 1.0f; to move object without using any buttons. Though i have not found if i have set Time.timeScale = 0.0f; mistakenly anywhere. May be the project has by default set itself to Time.timeScale = 0.0f;. Therefore, finally the solution is putting Time.timeScale = 1.0f; in the Update function of a scene where you need to rotate or translate any object continuously using Update function.

The problem has been solved using Time.timeScale = 1.0f;