Problem with trigger

Im having a problem with my ai and my sword attack. The problem is when I attack the enemy, the sphere collider from enemy are the one that trigger the event instead of the capsule collider. I used the sphere collider to detect who is inside the enemy range (like who enter and exit)…

My damage script are attached to my player sword game object the I use the OnTriggerEnter event. How can I make it to ignore the shpere collider? My sword is set to is trigger and same with the sphere collider

EDIT: sphere collider have radius of 15

Looks like you want collision layers. Unity - Manual: Layer-based collision detection

Set your sword to a layer called “sword” and uncheck it’s collision in the collision layers section.