Problem with Unity Asset Store

Hi, i have a problem with my unity Asset Store. I dont know why, My Unity not connected to internet. my Unity say "You are currently offline" but, im connect to internet. in error log say “Peer certificate cannot be authenticated with known CA certificates url: https://kharma.unity3d.com/”. i`m really not understand about this… Please can anyone help me to solve this??? thanks

I’ve had the same problem off and on with my IT and firewall. I found if I launch my Unity Editor with Admin Privileges, the asset store launches.

Have you tried restarting Unity?
Can you access https://kharma.unity3d.com/ in a browser (is it a local network problem?)

Also related:
http://forum.unity3d.com/threads/83368-Problem-Opening-the-Asset-Store

It appears this happens sporadically. When it happens, please contact assetstore@unity3d.com so we can have a quick look at it.

HI DUDE>… I had the same thing for 3 days… i figured out that my AVG antivirus was blocking unity 3D … so i allowed all programs in my avg which solved the problem.

Hi, I had the same problem but I fixed it. If you have an AntiVirus like AVG, Avast… You must diactivate it or turn off the firewall to be able to access to Unity3D Asset Store;
Hope I help you with this.

Clearly a firewall issue.

Use Internet Explorer.

get a proxy like vpn

  1. Go to Internet Properties (Internet Options if you search on Windows 8)
  2. Go to connections
  3. Click on LAN settings
  4. Uncheck “Use a proxy server for your LAN”

Worked for me!

This worked for me.