Problems with debugging and not hitting breakpoints

For a while now a project I have just doesn’t want to hit any breakpoints. I’ve used both VS 2017 and VS Code, while VS 2017 tells me after I attach the debugger that it can’t find a corresponding location and VS Code just does nothing.

I’ve tried clearing the project files and cloning it from git, I’ve tried reinstalling VS and all appropriate tools, and nothing seems to be working. The biggest problem, is that other projects still work when debugging and hitting breakpoints but not this specific one.

Any ideas what may be happening?

Hi @srylain, It would be very helpful if you could provide a minimal project for investigation. You can report it using Unity Editor with your project attached and provide me an issue number so we could try identifying the issue and get it fixed.

For my experience, if only one or certain number of your scripts have problems with breakpoints, it might because of your setup of project.
I couldn’t debug in one of my scriptable render passes, it turns out to be that I was using a empty renderer feature in custom forward renderer asset, after recreating a new feature asset, it works just fine.