Problems with OpenXR: Black screen or no headset movement.

,

Hi everyone, I am facing a bug where the screen becomes black once I click play or in build (not even Unity logo is showing).

I am using Unity 2021.2.12f1, Windows Desktop target, OpenXR and WMR headset. Already installed and set up Microsoft Mixed Reality OpenXR plugin. Tried switching the Build target to Universal Windows Platform but that didn't solve the problem.

Weirdly, I am not facing this problem with Unity 2020.3.26f1 and Desktop target, but its also not stable there, as I wouldn't be able to move the headset sometimes or sometimes it moves very slow, but no black screen on Unity 2020.

What do I do in this case?

Thanks for any help I could get.

I have to disable HDR on camera to get rid of that

1 Like

Oh! I need to try that.

Disabling HDR in Unity 2021.3.25
9035197--1247467--upload_2023-5-24_13-14-6.png
Just made the HMD go gray instead of Black and the headset is not tracking with the OpenXR examples project
https://github.com/Unity-Technologies/XR-Interaction-Toolkit-Examples

I don’t remember how I fixed it but I think I did the following:

  • Updated Unity
  • Made sure the XR keyboard Simulation thing is deactivated
  • Made sure the opened view is Game view in the Unity editor