ProBuilder - default material with LWRP

Using ProBuilder with the LWRP, I’m having issues with the grid texture once the shape is created.
It shows the correct texture before the cube is created, but afterwards it is gray. Any Ideas why this is happening?



Not sure if anyone found the answer to this or not, but I just figured it out - just so everyone knows.
What I did was, after importing Pro Builder into project, go to the Project tab and look for Packages.

  1. Tick Packages open
  2. Tick Probuilder open
  3. Tick Next probuilder open
  4. Tick Materials open.
  5. Right click anywhere and hit Show in Explorer
  6. Drag the Textures and Material to somewhere else in project (this will essentially duplicate it).
  7. Change the new Mat to LWRP shader
  8. Then make that the first material in the Material Editor.

Not sure if you have to drag the textures folder or not, but did it anyways.

I have the same problem, I haven’t found a solution yet but I really hope to have an answer too as it’s make it impossible to do precise work when extruding faces and stuff.

@Zundrium @Sekamelica There is a workaround by creating your own material using Lit or SimpleLit shader (if you are using URP but I suppose LWRP have corresponding shaders) pointing to GridBox_Default and then add that material as default in ProBuilder preferences or another way is to add that material in the ProBuilder Material Editor list that you can easily select with alt+number.

UPDATE: in latest package versions there are optional downloads to support URP and others.