"Project incompatible, New version of Unity required"

[18273-unity+error.png|18273]

Hello, guys I have encountered the error message when I tried to open a new project.
previously the Unity Project was made in Unity in Mac Pro which is higher version than my Window8 laptop. so should I re-install the higher version to my Window8 just to open the previous project for it to be revised?

I appreciate your answer and thanks in advance

Nobody here will tell you “Yes sure, just press continue”, because there always is a fail percentage in everything. You should make a copy of your project, in case it fails and corrupts the project.