Qcar Build Fail


i’ve just gone through the steps on building a QCAR project with the Unity Extension, unfortunately when i build in Xcode i’m getting this error:

‘QCARUniytPlayer.h’ file not found

I looked in the Libraries folder and found a shortcut to the file, copied in the original, and nothing… well, the same thing.

I’m sure i’m probably missing something obvious, any help would be greatly appreciated,



The generated Xcode project does not have double quotes around Header Search Paths. Getting rid of spaces in your directory structure will fix this but you can also fix it by adding double quotes around the entry in Header search paths.


should be:


The QCARUnityPlayer.h is in unityproject folder projectname->Assets->Plugins->IOS,
copy this data to the XCode projectfolder projectname->Classes. Than its ok, I have this prob after the Unity Update to 3.5

This worked for me:

I found that amending the Xcode Build Settings by simply putting quotes around the header path did the trick:


‘QCARUniytPlayer.h’ file not found



Turns out the issue was that I had a space in my directory structure, rebuilt from unity without this and worked a treat.

The QCARUnityplayer.h is in Unity project folder Projectname->Assets->Plugins->IOS copy to the Xcode Folder Projectname->Classes. After the update to Unity 3.5, i have this prob. :slight_smile: