QualitySettings Texture Quality not working - but MipMaps On - iPad2

Edit: this works on iPhone5s perfectly but not at all on iPad2 !?

So to test this because it wasn’t working i’ve just reduced it to a very simple totally fresh project.
Unity 4.6.8

The project has one 4096x4096 truecolour texture - which has mipmaps turned on.
The texture is being used in a single SpriteRenderer object.
The default Quality Settings for the project have “Texture Quality” set at HalfRes.

When the project starts up i print out the QualitySettings.masterTextureLimit and it is 1 … which should be the first level of mipmap… which is correct.

BUT - the memory profiler reports that the texture is sitting in memory at 85 megs… which is its full res size… -
I’ve tried fiddling with the texture settings… nothing seems to make any difference…
Any Clues greatly appreciated!

Hmmm… ok so… it seems this was working all along and what wasn’t working was the Unity Memory Profiler! Only from iPad2… from iPhone5s it worked fine… on iPad2 if I used the Xcode memory profiler instead then it all made sense… less memory when using QualitySettings.masterTextureLimit at 1 than 0… etc…