Rain drops through object/ collison

Hello everyone,

I got a problem.

I have the simple weather control pack with rain as particle.

When I drop the rain it goes through the ceilling in a room.

Is there an way to get it drops on the ceilling instead of going through?

Kindly regards,


Hello @Melchet,

A few steps to help you out.

  1. Go into the particle system options,
    and find the “Collision Tab” , tick
    it to activate it.
  2. Under That “Collision” Tab, put in
    these settings :
    -World Collision , instead of Planes on the first sub-setting.
    -Lifetime Loss: 1;
    -Collision Quality: High;
  3. Tick in “Collision With” all the
    layers that have your prefabs on, with
    meaning the objects that you want
    this particle system to collide
  4. Be Sure to Prefab - '‘Apply"’ these
    new settings on your particle system
    if you are editing the prefab
    instead of a scene GameObject.
  5. Be sure that the GameObject you
    want to collide with the particles
    has a Collider component and it is
    on the right Layer that your
    ParticleSystem is looking up.

Plus 6. Create a cube, and a standard particle system, create both, then follow the said points, then, try implementing on your own mesh and particle system.

I hope this helps you!


Hello Leoo,

I have all done what you did, but it didn’t work, rain still goes through ceilling…

I only don’t understand what you mean at point 5.