Reached the maximum polygons limit (256)

I have this error spam all the time:

Failed to create Convex Mesh from source mesh "Object002". Reached the maximum polygons limit (256)...etc...
(many different meshes mentioned)

What a nonsense! (Although I don't even add Convex Mesh on that meshes)

It's likely an imported object has generate colliders or some such.

One of them it's skinned mesh, and it can't have collider at all. In any case 256 polygons. What?

Failed to create Convex Mesh from source mesh "Object002".

Convex mesh collider have been limited to 256 polygons (or rather triangles) probably since unity's creation.
Convex Tick the checkbox to enable Convex. If enabled, this Mesh Collider collides with other Mesh Colliders. Convex Mesh Colliders are limited to 255 triangles.

But if what you say is true:
Although I don't even add Convex Mesh on that meshes
It might be a bug.

Just double check (all) Object002's collider settings.

Haven't tested the 2020.1 alpha myself yet.

Fuzzy, if I click on an error, this provides me with a project window when these objects are in folders (not on the scene, but just fbx, I have not even touched them since the update)

Then the only thing i could see them having done for their "performance by default" motto would be that the "generate colliders" checkbox on the object importer is set to generate convex colliders by default - since they're generally better performing than concave colliders - but don't have a check for the triangle limit or something.

But that's just random guessing.

Maybe just send them a bug report with a minimalistic project containing the object that causes this problem.

If this used to work before the update, please submit a bug report with a (minimal) reproduction project.

I have a similar problem, a mesh collider that works perfectly well on 2019.2 gets this error on 2019.3.

Just want to point out that, in case this is a bug, it was introduced during the 2019.3 cycle. Hope this helps.


Same for me in 2019.3. Almost all objects with convex colliders got mad. Its showing this error, but still it works.

A bug report with a minimal reproducible would be much appreciated.

The issue has been reproduced and is now visible in the issue tracker:

It would be really helpful if this error was displayed in the inspector. Also, having some sort of built-in solution, aka mesh decimation of some sort...


I just updated my game project from Unity 2019 to 2020 and am getting this error on one mesh... I tried simplifying it in blender but to get the error to stop displaying it REALLY needs to destroy the mesh... (a circle that becomes an octagon isnt really nice) - rectangles becomes triangles and so on... ;)

I never had this issue with older Unity version (this game has gone from pre-20xx unity, to 2016, 2017, 18, 19 and now 2020) and only 2020 has issue with this particular blender file... any idea on how to fix it without destroying the mesh itself? (Please note that I am SUPER noob when it comes to actually editing meshes)

EDIT : after way too many hours of trying everything to solve this, I found out that by setting the option in Unity for "Normals" to Calculate instead of import, then the problem was gone! No idea if this is part of the original bug that was reported (and supposedly fixed) but using 2020.1.3f1 I was having this problem... and now its fixed!

So hopefully what I found might be able to help someone else upgrading and googling for the answer as this thread was the first one that popped when searching for the error message! ;)


[QUOTE= I found out that by setting the option in Unity for "Normals" to Calculate instead of import, then the problem was gone! [/QUOTE]

Hi Firehawk.
I'm getting an error "Couldn't create a Convex Mesh from source mesh "object" within the maximum polygons limit (256). The partial hull will be used. Consider simplifying your mesh." But the resulting collider looks OK. Can you provide a link for the above. (its an underline not a link currently) please. I cant find anything about using normals to calculate a convex collider.

1 Like

Check If you have "static" for lightmaps checked, if so uncheck it