Real time shadows in a lightmapped scene (Android)

After baking a scene using single lightmaps (or dual lightmaps for that matter), the non-static objects don’t cast shadows anymore. In the editor, the objects do cast shadows. The problem is when it is built and run on the Android device.

I:-

  1. Have checked “cast shadows” on the objects that I want to cast shadows.
  2. Have set the main directional light(the one that is casting the shadows) to “Real time only” and Important.
  3. Am using the forward rendering path on Android and PC. This device(SGS4) supports OpenGL ES 2.0 so I don’t think it’s a hardware issue?
  4. Have checked the quality settings and have allowed shadow casting for the Android platform.
  5. Have gone through the Unity manual a lot of times to check and counter check something I must have missed.

Thanks for your time. Any help/suggestion is appreciated.

Normally you will need Deferd rendering for dual light-maps:

Dual lightmaps by default can only be used in the Deferred Lighting rendering path. In Forward rendering path, it’s possible to enable Dual Lightmaps by writing custom shaders (use the dualforward surface shader directive).

http://docs.unity3d.com/Manual/LightmappingInDepth.html

I used a shadow projector to emulate the effect. Increases performance drastically versus RT shadows. Mobile platform, nobody cares whether the shadows are realistic or just round blobs.