Really dumb problem

In the MonoDevelop, the cursor changes words when typing, instead of adding new words. This is just problem to me, and caused me a bit of frustration. I know I sound like an idiot, but can anybody tell me how to do this?

It’s only a dumb problem because you failed to explain it in a way that made enough sense for anyone to give you an answer.

Go to Preferences / Text Editor / General. Uncheck the “Enable code completion” box.

Is it fixed now?

I now remember that infuriating me the first day I tried to use MonoDevelop. If that’s not what you were talking about, rephrase your question because I really have no clue.