Realtime light is leaking through walls?

Hey so i’m problem with my realtime light in Unity 5. It has shadows and all the objects it is hitting is supposed to cast shadows, but it’s leaking through the top of the roof and the right side?

I know that for the new GI system, “bounce intensity” will cause it to leak in the current version of Unity. I have a different light in another room that had the same problem until I set “bounce intensity” to 0, and it stopped leaking. But this one has it at 0 also, but continues to leak. Any ideas?


Hi! I know it is a bit late but the leaks are present in Unity 2017 too. I found that setting the Normal Bias to, or close to zero in the Directional Light’s settings closes the “gaps” which appear on hard edges of the mesh.

Try adding thickness to your walls, I had the same problem and Also had thickness to my walls but they where seperated so the inside wall and outside walls where differnt meshes. After added a simple extruded face to the walls and now no light leakage!! try it out

The light is leaking through perfectly attached cubes (arranged in Unity Ediotr). I don’t see why…
Someone posted the solution for directional lights, which also solves shadow “stripes” on strange angles. The trick is to play with Shadow Bias which, sadly, only works on Directional lights in Unity 5 for some reason…

BIG BUMP!

In the lightening tab, create a new Light Parameters Asset and play with the “Modelling Tolerance” value in the realtime GI section. (It’s an option in the progressive light mapper. Not sure when it was added but I’m using Unity 2017.3)

I do not know if I am answering late.
I have experienced this issue in URP. After trying different settings I found the resolution.
Try changing: Lighting property > Cast Shadows > Two Sided. Also mark “Stitch Stream” to true.

After changing the properties