Realtime shadows not working on compatible video card

I've been trying many options to enable soft and hard shadows, but they won't show up.

I'm running Unity 3 Pro Trial on Windows 7, with a GMA 3150 Graphic Card. The graphic card itself is pixel shader 3.0 compatible, and superior to GMA X3000 (as it's written on the documentation). So, it should work well.

However, realtime shadows are not working. I set up a directional light, a cube and a plane. Then, I turn on every possible "Cast/Recieve Shadows" option on the cube and on the plane. Finally, I set up the directional light to cast hard or soft shadows, with the "Important" render mode assigned.

Now, no matter if I change the editor quality, realtime shadows won't show. Is it a problem with the graphic card? I cannot think about other solutions...

It wouldn't be a graphics card issue, yours seems like a good one. Make sure the billboard setting is on a high number, as that helped with mine. If you are still experiencing issues create a lightmap for your terrain, good luck!

Hi there.

Have you checked that you project Rendering Path is set to either "Forward" or "Deferred Lighting"? These settings are, as far as I know, new to Unity 3 and affect the ability of lights to cast shadows.

Settings are found under: Edit > Project Settings > Player