Rebuilding Library because the asset database could not be found! any help?!

i tried to get a couple tutorials for unity and they download okay, but when i open the file the scene veiw has nothing on it. all the files and things that came with the download are in the hierarchy but nothing shows up. in some cases it will say "Missing (mono script) how to i fix something that is missing when i downloaded it straight from unity??? aren't their tutorial suppost to actually work on their program. i just want to know what going on. if anyone could help. they are all also missing "mesh" and :physical matieral" if im doing something wrong i would love to know. but all i did was download it and try to open the file. is the file messed up??

Can you give us the address of the data you are downloaded ? Usually you only need to Open the project directory and everything is fine.

I've got this kind of problem when I'm using SVN and I forgot to enable the .meta, but i doubt that you get your tutorial from an SVN repo...


I found that if I opened the scene through the Unity Launcher I would get the same error:


144382-capture1.png



but if I opened the specific scene through file explorer, BlockGame\Assets\Scenes\BlockGameScene.unity
then it would open OK.
Just as an idea if other people are having this issue as well.