RectTransform Anchor gizmos, not visible in scene editor

Full disclaimer - I have been searching for an answer to this, and have had no luck in the past hour trying to find the solution; so apologies now if this has already been answered somewhere.

I recently upgraded my free Unity build to the new 4.6.1 and I’m very excited to try out the new GUI tools that we have at our disposal. I set up a new project, used the 2D defaults (I’m primarily just messing around with elements) and everything seems to be going fine.

Until I realize, that upon adding a button to my Canvas, I can’t see the anchor points of the parent canvas in relation to my button.

For example, the tutorials all show this nifty little gizmo:


But in my own scene editor window, I don’t see that same gizmo - anywhere. Is there a “show anchor gizmo” setting that I’m missing somewhere?! Or is this some kind of frustrating limited feature to only Pro licenses? I get the same blue circles / orbs for resizing the element, but those darn arrows for the anchor aren’t showing up.

Per the usual - any and all help is enormously appreciated!

I have the same issue too on 5.2.1p4 (64bit, Windows).

I think it is a Unity Editor’s bug, but a workaround is there.

  1. When RectTransform Anchor gismos are hidden, create a new scene (File → New Scene).
  2. Then, close the Unity Editor (File → Exit). No need to save the created new scene.
  3. Run Unity Editor and open your project.
  4. Open a scene that contains uGUI objects.
  5. Gismos are shown now!

What you need is use Rect tool to see does not matter you work on 3D or 2D .

If you still can not see the anchors Set Layer to Default

if any of your Inspector window (as you can have more than one Inspector windows at a time) is LOCKED or in DEBUG mode, the anchor gets hidden

And now for an interesting turn of events - this was the first time I’ve ran 4.6.1 on this computer, apparently restarting the machine was enough to get the gizmo’s to show up.

I’m at a loss. O_O

the same problem with me. I solved problem by changing debug mode to Normal at inspector window.

There is no button, to my knowledge that allows you to turn anchors on/off. They should always be on.

There are however a few ways that should work to get you to find them.

First off, I am sure you are aware, they are not always together as shown in your picture. They are 4 seperate “pointers”.

Second if you use the presets on the RectTransform in the inspector you should be able to set it to center/center and then all the “pointers” will be in the very center of the Parent Object and in the design in which your picture shows.

If you still cant find them, try setting it to stretch/stretch and you should see one “pointer” on each corner of the Parent Object.

Hope this helps, if not please let me know. I can always fiddle around a bit more.

I had the same issue, but in my case the UI Canvas and all its children were not set to UI, but the UI Layer was set to invisible it the Scene editor.

The solution was to set all the UI elements in the scene to use the UI layer, then click Layers in the top right corner and set the UI Layer visible again.

For some reason the anchor gizmos are not on the same layer as the UI element selected, maybe this should be brought up to the Unity guys?

I had the same problem, and got it to work (kinda), but none of the other solutions worked for me. I’m using 5.3.0f4 (64-bit Windows). It appears that the gizmos show up when I hit the [2D] button on the Scene window. They don’t show up when using the [3D] view.

If you have parent that is not Recttransform than anchor will not be visible.

same problem here in 5.50f3 no achors showing ?? major problem since I’m now trying to get are app to run with difference resolutions ??

even when i add a new Canvas i get the error and even in a new scene !!??!!?

Even in late 2017 i’m experiencing the same problem. ^^
All my parent objects do have a rect transform (except the “driven” Canvas) but i can’t see any anchors if i child my new buttons to any other UI element with a rect transform. Before i made them a child, the anchors were visible, but afterwards they disappeared.
None of the suggested different “solutions” worked for me. I tried:

Layer to Default

  • Reassigning to UI Layer and re-enabling visibility of UI Layer
  • Inspector to Normal (Some say anchors disappear in Debug Mode)
  • Restarting Unity
  • Restarting PC

I need the anchors for “InfoHeader” which is a child to “InfoButton”. The Inspector image shows the parents settings, meaning those from “InfoButton”.

Any other tipps or hints to to solve this? Many thanks for any answers!

I tried everything in order to fix this after having the issue in 2018.3.6:
• Upgrading Unity version to 2018.3.7

• Deleting Library and reimporting

• Deleting ProjectSettings and replacing with a standard version

• Resetting colours in editor preferences

• Restarting

• Looking through the source for RectTransform’s Editor

None of these resolved the issue.

In the end I resolved it by reverting the project back by a week or so and then bringing it back to the default state. I have no clue what this resolved - the only big change in this time was updating the Gaia plugin to a new version. This isn’t an awfully transferable answer to help other people, I’m afraid!

Was able to solve it in another way when a UI element was concerned.
Apparently the UI element (or its parent) had a regular “Transform” component instead of “Rect Transform” and it affected its children. Once I switched “Transform” with “Rect Transform” the issue was resolved.

Make sure the gizmos button is turned on which you can see at the top of the scene window!