Reduce Build Size Problem?

I have recently finished an app for Android. The app was around 159 MB, which is REALLY big to me! I have followed Unity’s Documents about reducing the build size by compressing and reducing texture sizes.

I built my game before I compressed everything (Sounds and Textures), opened up the Editor Log on the Console, and it showed that 146 MB (YIKES!) of my game were from textures! I fixed everything up and I got this:

Textures      24.2 mb	 54.5% 
Meshes        4.3 mb	 9.8% 
Animations    0.0 kb	 0.0% 
Sounds        11.1 mb	 25.1% 
Shaders       157.1 kb	 0.3% 
Other Assets  57.6 kb	 0.1% 
Levels        170.5 kb	 0.4% 
Scripts       175.4 kb	 0.4% 
Included DLLs 4.1 mb	 9.1% 
File headers  127.7 kb	 0.3% 
Complete size 44.4 mb	 100.0% 

I was really happy that it shows 44.4 MB, thinking the app is now under the 50 MB limit on Google Play.

But then I noticed that my actual Build .APK on my Desktop is 121 MB! I don’t know how or why the log shows me 44.4 MB but the app is 121 MB… Maybe I’m missing something noobish… An explanation would really help! :slight_smile:

You must have the “Development Build” checkbox ticked in the Build Settings. That adds all unity’s debugging symbols into your build, which, on an empty project amounts to about 66MB.