Relay allocation request fails

Hi there,

As information, we're currently update a game in production for 5 years, from UNet technology to Relay/Lobby package.

We're facing some issue while sending requests thanks to relay package.

What we've done :

  • Services are linked thanks to Project ID. Lobby package work like a charm, and we're able to create/join lobby inside this project, so this step looks OK.
  • Relay is Enabled for this project, on Unity service web interface.
  • We downloaded Relay Allocation Package (version 1.0.0-pre.4)
  • Installed sample Simple Relay Sample and launched demo scene.
  • After signed id anonymously (Player ID is retrieved), we tried to request some relay allocation and face this exception :

HttpException: Exception of type 'Unity.Services.Relay.Http.HttpException' was thrown.
Rethrow as RequestFailedException: Something went wrong.

Trying to dig some more info into this exception leads nowhere, and Something went wrong it's not really helping me here.

We tried to send List Region request, and same error is encountered.

My setup :
Mac Book Pro 16", 2021, Apple M1 Max, 64 Gb RAM, macOS Monterey 12.4
Unity 2021.3.2f1

Did I miss some setup to make Relay Sample working? Or my setup could be an issue here (M1 Max, I'm watching you)?

Regards

Auto update : Problem solved.

Changed my Unity version to : Unity 2021.3.8f1 .

Not sure if it’s the Unity 2021.3.2f1 version that cause the issue, or the Rosetta mode.

I’m now able to create allocation on Relay server.