[Release Blocker] [IN-68795] Foviation breaks soft particles, and other depth/stencil effects with visual artifacts on device

What happens:


What’s expected:

When using effects that rely on the depth and stencil such as the provided URP soft particles, all volumetric effects, on the asset store the image is distorted.
The distortion appears as a strange shadow of the stencil and sometimes a pink transparent artifact on the right side.

This applies to the following I’ve tried:
Unity provided URP Soft particles. (Attached in bug report)
Volumetric Light Beam - Tech Salad
Dynamic Fog & Mist 2 - Kronnect
Volumetric Lights 2 - Kronnect
Volumetric Fog & Mist 2 - Kronnect
Ethereal URP - Volumetric Lighting & Fog - ARTnGAME
Many other post process depth effects such as those used in water, reflections, and postprocess effects.

  1. How can we reproduce it using the example you attached
    Run the project on Vision Pro Hardware with foviation enabled.

Disabling foviation will prevent the bug but is not an acceptable workaround.

Adding #include_with_pragmas “Packages/com.unity.render-pipelines.core/ShaderLibrary/FoveatedRenderingKeywords.hlsl”

or other vertex I/O attributes struct and SPI macros

@mtschoen https://feedback.unity.com/ is broken currently but I’m trying to upload via a bug report.
It is just taking a long time.



@egleiser I am seeing the Pink Bar on the right hand side when simply switching to the default Balanced URP asset. I was able to resolve it by disabling Quality > HDR on the Asset.

This fixes the pink bar but does not fix the main artifact I’m concerned about.
(Also we would like to use HDR)

1 Like

Agreed! Trying to help a little as I found the same thing.

Seems like HDR is just broken. Even simply enabling HDR on the Performant URP Asset introduces the pink bar, without any other changes.

1 Like

Still not fixed in latest release. Any ideas @mtschoen?

Hi there! Thanks for bringing this to my attention. I don’t have the bandwidth to look into this right away, but we have someone assigned to take a look in the next week or two. We’ll keep you posted.

1 Like

Thank you!
We really need this for volumetric fog and lighting.
Seems to work on Meta VR, but not Vision Pro

Disable foveated rendering before Blitting and enable it before cmd.DrawRenderer(s), use positionCS.xy(SV_POSITION)/_ScaledScreenParams.xy(if downsampling, use _CustomRT_TexelSize.zw) instead of screenPos.xy/screenPos.w(calculated by ComputeScreenPos()) to sample render texture in other forward shader.I don’t know why, but it works.

How are you disabling foveated rendering before Blitting?

Add cmd.SetFoveatedRenderingMode(FoveatedRenderingMode.Disabled) before cmd.DrawMesh(fullscreenmesh) or Blitter.BlitCameraTexture in renderpass class, and add cmd.SetFoveatedRenderingMode(FoveatedRenderingMode.Enabled) before cmd.DrawRenderer(s)

1 Like

Any ideas to sovle the flickering problem with the VFX particles when using alpha blend?