Removing bump when going through two adjacent colliders

Hello,

I’m a newbie in unity, and had only finished the roll-a-ball tutorial a few days ago. To challenge myself, I wanted to expand the game into a 3d platformer-esque game, creating a “level” out of 3d cubes and other objects

However, i noticed that sometimes, when the player ball goes through two perfectly adjacent colliders, a small ‘bump’ up may still occur.

51096-new-canvas.png

Several search attempts has shown that this is a pretty common problem regarding ghost vertices, but I’ve yet to find a single working solution. I don’t think a charactercontroller will work for such a physics-reliant minigame, and some other solutions that involve editing “Min penetration for penalty” to 0 no longer work since in unity 5 it has been changed to default contact offset (which has to be strictly positive, apparently).

Some other solutions involve replacing everything with a single solid collider, but as you can see from the screenshot its not really feasible (plus it’s not really the most elegant of solutions either)

Alternative solutions and help will be much appreciated, thank you in advance!

I think I found a pretty acceptable fix! In Unity 5, reducing Min penetration for penalty to 0 in Settings->Physics no longer work since its replacement, Default contact offset has to be strictly positive. It’s still possible, however, to use an extremely small number (i used 1e-7) to apparently emulate the same results.

It might not be a perfect solution, but I believe it has mitigated the chances of the problem ocurring significantly

I also had this problem, and none of the suggestions worked from here. However, setting collision detection to Discrete (the default) on the player’s RigidBody (using a spherical collider) solved this for me. I believe that with Continuous Collision Detection, Unity’s secret physics system was registering 2 or more simultaneous collisions, and this was causing my player to get stuck.