Render Texture Mip Maps Missing

I’m rendering an animated spritesheet (that is played using a custom shader) for a crowd to a RenderTexture (RT) so that I can use it around the stadium without relying on the expensive spritesheet animators (as well as tinting parts for clothing variation & reusing existing quad planes in the scene etc). However; I’m finding I get no mips with the RT.

I read around and found a post from years ago suggesting RT mips might not be supporting on all platforms (I’m on Android) but I just made a test scene in a D3D11 project and witnessed the same issue. I also tried disabling transparency but that didn’t make the mips appear.

According to Unity - Scripting API: RenderTexture.useMipMap they should be on by default. Is this a limitation of method I’m using?

In some cases you have to manually enable useMipMap and generateMips for them to work. I’ve had this problem when working with realtime cubemaps before.

So we found an even easier way of doing it. Turns out Unity has a hidden Debug Inspector where the options are hidden. Didn’t even need any code!

Thank you :slight_smile: a response! This is the fourth question I’ve asked in 3 years and the first one I’ve gotten a reply to :slight_smile:

I’ve already asked one of our programmers for help knocking up the c# useMipMap code (hopefully get some results today) but great to hear that solved it for you. Sounds like the docs need updating to mention they “[aren’t always] enabled by default”.