RenderQueue must be set to 2501 or higher for Example/URPUnlitShaderBasic to display


I have been studying shader code and referring to the documentation “Writing Shaders - URP - Basic Unlit Structure” (URP unlit basic shader | Universal RP | 13.1.9).

I tried copying the ShaderLab code provided in a new project created with the 3D (URP) template. However, I encountered an issue where Example/URPUnlitShaderBasic does not display unless the RenderQueue is set to 2501 or higher. In the documentation’s images, it is shown that the default RenderQueue of 2000 displays the shader correctly.

I think it’s a problem with my environment, but I don’t know the cause.
Any advice?

I am using Unity version 2021 .3.18f1.

Thank you in advance for your assistance.

I apologize for the inconvenience. Please note that I am using automated translation for this communication, so I apologize if the resulting sentences sound awkward or incorrect.


Would you kindly please report this issue via the Bug Reporter tool?
It might be that it’s not a known issue on our side (I tried looking to see if such issues were reported but didn’t find any), so your bug report would greatly help us in figuring this out and perhaps even fix it, if it’s not a project specific issue and caused on our end.

Please make sure to write the exact steps needed to be taken so that the reproduction would be visually seen. Also make sure to attach a reproduction project and any visual material so that when testing our CQA team can verify that they got the same results. If you can, please use this template:

How to reproduce:

  1. Open the attached project
  2. Do this
  3. Do that
  4. Select this
  5. Observe that

Expected result: Something is visible, something is printed or something happens
Actual result: The opposite of what I expect happens

Reproducible with: Editor version I am using (e.g: 2021.3.xf1)

Reproduced on: The OS I am on (e.g: Windows 11, macOS Ventura 13.1 (Intel/Silicon))